Image and PDF CDN is throwing SSL handshake errors
Incident Report for AgileMD
Resolved
We resolved an errant configuration on the non-SNI CDN. Requests to that hostname are no longer receiving the SNI headers and content is downloading to all clients as expected. The fix has been independently verified on the affected platforms.
Posted over 3 years ago. Aug 04, 2014 - 15:23 PDT
Identified
This incident appears to be related to SNI support on our main CDN. Clients accessing CDN resources using the CloudFront hostname ("https://d29l706z9xvnmx.cloudfront.net" as opposed to "https://cdn.agilemd.com") are receiving the SNI header anyway which is causing request failure. This is impacting certain versions of our Android app as well as Internet Explorer users running Windows XP. We are currently working with upstream partners to resolve this issue.
Posted over 3 years ago. Aug 04, 2014 - 10:40 PDT
Investigating
We've identified an issue related to a limited set of resources which prevents some content (certain images and pdf files) from being delivered to the client. This error is related to a spike in handshake failures observed on the asset CDN.
Posted over 3 years ago. Aug 04, 2014 - 08:59 PDT